WordPress4.9.2にアップデートしたらエラーに?

WordPressで4.9.2にアップデートしたら管理画面にログインできなくなりました。
ログインの際に下記の警告が出ます。

よくあるプラグインの副作用かと思いましたが最近は全くプラグインを入れていません。
なので潔くあきらめて、サーバーのカスタマーサポートに問い合わせました。
するとサーバーのPCREライブラリが古く、4.9系のデータベース処理に対応できていないとのことでした。
ついでに現行サーバーでの回避策を教えていただいたのでさっそく試しました。

修正するのは/wp-includes/wp-db.phpの1649行目と1653行目。
下記の”$pattern =”の箇所で、何カ所か大文字の「P」を追加しています。

●修正前コード

●修正後コード

この2行を修正してFTPで上書きしたらすぐ直りました!!
WADAXカスタマーサポートの方、ありがとうございました。助かりました。